Users can use a new setting for the plugin (--max-inclusion-depth) to limit it.
This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10.
Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.
Analysis and contextual insights are available on OpenCVE Cloud.
No solution or workaround provided in the CVE record.
Additional remediation guidance may be available on OpenCVE Cloud.
Tracking
Sign in to view the affected projects.
| Source | ID | Title |
|---|---|---|
Debian DSA |
DSA-5948-1 | trafficserver security update |
EUVD |
EUVD-2025-18741 | ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue. |
Wed, 16 Jul 2025 15:45:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| Metrics |
epss
|
epss
|
Tue, 01 Jul 2025 22:30:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| First Time appeared |
Apache
Apache traffic Server |
|
| CPEs | cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:* | |
| Vendors & Products |
Apache
Apache traffic Server |
Fri, 20 Jun 2025 16:15:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| Metrics |
ssvc
|
Thu, 19 Jun 2025 12:15:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| Title | trafficserver: Traffic Server ESI Inclusion Depth Vulnerability | Apache Traffic Server: Remote DoS via memory exhaustion in ESI Plugin |
Fri, 20 Jun 2025 05:15:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| Title | trafficserver: Traffic Server ESI Inclusion Depth Vulnerability | |
| References |
| |
| Metrics |
threat_severity
|
cvssV3_1
|
Thu, 19 Jun 2025 12:45:00 +0200
| Type | Values Removed | Values Added |
|---|---|---|
| Description | ESI plugin does not have the limit for maximum inclusion depth, and that allows excessive memory consumption if malicious instructions are inserted. Users can use a new setting for the plugin (--max-inclusion-depth) to limit it. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.5, from 9.0.0 through 9.2.10. Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue. | |
| Weaknesses | CWE-400 | |
| References |
|
Status: PUBLISHED
Assigner: apache
Published:
Updated: 2025-06-20T13:56:54.082Z
Reserved: 2025-06-09T23:10:28.606Z
Link: CVE-2025-49763
Updated: 2025-06-20T13:56:20.661Z
Status : Analyzed
Published: 2025-06-19T10:15:21.887
Modified: 2026-06-17T09:31:55.277
Link: CVE-2025-49763
OpenCVE Enrichment
Updated: 2025-06-20T16:09:47Z
-
CWE-400
Uncontrolled Resource Consumption
Debian DSA
EUVD